Jisho

×
44df21eb528311478eda0b1f6a4b29a4
27 Replies ・ Started by nitzi at 2017-09-29 19:53:00 UTC ・ Last reply by Kimtaro Admin at 2018-03-04 07:25:18 UTC

Draw feature in Chrome not working

For some reason, the Draw function of Jisho.org doesn't work on Chrome nor FireFox, but it does work on Microsoft Edge.
Can someone help me get it to work on Chrome please. (I prefer Chrome)

Thanks

2986330e38386f92fee4774b0c54ed66
Kimtaro Admin at 2017-10-07 00:22:58 UTC

What device and operating system and version of chrome are you using? It works for me in chrome on Mac OS X.

83653a964d1ebf1dff492aa188412614
jakobd2 at 2017-10-07 02:33:25 UTC

Considering the mentioning of Microsoft Edge, I'd guess they use a Windows 10 device.

2986330e38386f92fee4774b0c54ed66
Kimtaro Admin at 2017-10-12 22:00:33 UTC

Yeah, and it’s probably a tablet. I’ve gotten scattered reports about that combination before. So I’m adding this to that bug ticket.

44df21eb528311478eda0b1f6a4b29a4
nitzi at 2017-10-15 23:27:15 UTC

I use a Windows 10 PC (not a tablet), and it's "Version 61.0.3163.100 (Official Build) (64-bit)" (the latest version).

44df21eb528311478eda0b1f6a4b29a4
nitzi at 2017-10-15 23:33:17 UTC

Chrome is version 61 ⇈

2986330e38386f92fee4774b0c54ed66
Kimtaro Admin at 2017-10-15 23:31:57 UTC

@nitzi thank you for the details. I’ll try it out in an emulator and see if I can replicate the bug.

6ee23c5fa55b37168c3f360dded0acaa
Leebo at 2017-10-15 23:33:37 UTC

I've had times where the draw feature goes back and forth between working and not working, on PCs using Chrome. If it happens again, I'll try to document the specific situation, but hasn't been device dependent for me.

44df21eb528311478eda0b1f6a4b29a4
nitzi at 2017-10-19 01:29:36 UTC

any progress?

2986330e38386f92fee4774b0c54ed66
Kimtaro Admin at 2017-10-20 22:13:50 UTC

I just tried in Chrome 62 in Windows 10 and it was working fine.

@nitzi is it consistently not working? Do you have any extension installed? If so try disabling them and see if that fixes it.

44df21eb528311478eda0b1f6a4b29a4
nitzi at 2017-10-25 12:38:26 UTC

It's consistently not working :(
I disabled all my extensions and userscripts, and it still doesn't work.

2986330e38386f92fee4774b0c54ed66
Kimtaro Admin at 2017-11-05 19:27:10 UTC

@nitzi Do you use a mouse as the input device, or a tablet or something else?

22716fd689cc126ef5c542ff4506095f
Rumite at 2017-11-05 21:16:30 UTC

I have the same problem, but only in Chrome, it works in Firefox.
I'm using Chrome 62 and Firefox 56.0 on Ubuntu 16.04 LTS. I have a graphics tablet but I tried without it and same results.

2986330e38386f92fee4774b0c54ed66
Kimtaro Admin at 2017-11-05 23:07:29 UTC

Can you describe how it is behaving? Is it not returning any results, or is it returning a single result “f”?

2986330e38386f92fee4774b0c54ed66
Kimtaro Admin at 2017-11-05 23:24:47 UTC

I've dug into this a bit more and there seems to be something odd going on on the server side. I'll post again when I know more/have a fix.

22716fd689cc126ef5c542ff4506095f
Rumite at 2017-11-06 11:18:26 UTC

Sorry, I wasn't clear enough. The draw function actually works, but I can't see what I'm drawing.
https://i.imgur.com/dbOwuH0.mp4
I think that's from my end, but Jisho is the only website where I have this issue.

2ea591a11b65d06b9d3b5e76d6c9d9ed
dijek at 2017-11-07 02:08:10 UTC

I don't know how helpful it is, but on my Windows 10 laptop that has a touch-screen, in chrome, I can use my touchscreen but my mouse doesn't work. Also, sometimes I can't see the lines. I don't know why I couldn't use the mouse because I think the touch-screen just emulates it online.

2986330e38386f92fee4774b0c54ed66
Kimtaro Admin at 2017-11-07 20:04:52 UTC

@Rumite Ah, that is probably a different issue, one that I also haven't been able to replicate or fix yet.

@dijek That does help - I wonder if the drawing library we use doesn't support touch events properly on all platforms.

44df21eb528311478eda0b1f6a4b29a4
nitzi at 2017-11-07 20:21:21 UTC

I use a mouse

2986330e38386f92fee4774b0c54ed66
Kimtaro Admin at 2017-11-07 20:25:00 UTC

@nitzi In what way is it not working?

Is it showing kanji results, but no strokes when you draw?

Is it showing the strokes that you draw, but returns nothing at all?

Is it showing the strokes that you draw, but returns only "f" as the result?

44df21eb528311478eda0b1f6a4b29a4
nitzi at 2017-11-10 18:41:12 UTC

Throughout the video, I'm clicking and dragging (I don't know how to show clicks).
https://streamable.com/w2gg6

44df21eb528311478eda0b1f6a4b29a4
nitzi at 2017-11-16 03:44:14 UTC

@Kimtaro I posted a video ↑ showing what happens. I really want this to work. Please help 🙏

2986330e38386f92fee4774b0c54ed66
Kimtaro Admin at 2017-12-26 23:44:28 UTC

@nitzi Thank you for the video, that is not something I've been able to reproduce. Could you open the developer console in your browser and see if there are any errors? In Chrome you right click anywhere on the page and choose "Inspect", and then "Console" in the window that appears.

5da43a3a84fc2a4aebb36de5362d4327
Redarian at 2017-12-28 05:50:43 UTC

Howdy howdy! Signed up to participate in this thread. I'm on a Windows 10 laptop, a Dell Inspirion 5759 Signature Edition, with a touchscreen. I've been using Google Chrome (recent version 63.0.3239.84), and have been using the draw feature seamlessly for the last two days.

About thirty minutes ago, the website's draw function has stopped responding at all to my mouseclicks, from both my laptop's touchpad and my external wireless mouse. Hard refreshing the page, restarting the browser, and rebooting the computer have not fixed this.

In addition, the website is bouncing back and forth between working with my touchscreen. Sometimes, I can draw using my finger on the screen just fine. Other times, I cannot see the lines I'm drawing--but the search function is still working. So if I am careful and trace a kanji in the draw field, I can still get proper search results, but I cannot see any of the lines I've "drawn" with invisible ink. This problem is inconsistent. At this moment, in the tab I'm writing this post in, I cannot see lines in the Draw function; but I have another tab open to the home page, where the draw function was invisible for a bit, then worked, then didn't, and it's working right now.

Opening the console on my separate Jisho.org tabs, with both working and invisible draw functions, I see the following error: "The SSL certificate used to load resources from https://bam.nr-data.net will be distrusted in M70. Once distrusted, users will be prevented from loading these resources. See https://g.co/chrome/symantecpkicerts for more information.."

~ ~ ~ ~ ~ ~ ~ ~

~ I cannot use the touchscreen in Edge, because attempting to drag my finger across the screen simply encourages my browser to try scrolling up and down on the page, even if the window is maximized and there's nowhere to scroll to. Edge is working just fine with my mouseclicks, though.

~ I do not have Firefox installed on this laptop, and so cannot test there.

5da43a3a84fc2a4aebb36de5362d4327
Redarian at 2018-01-01 22:04:02 UTC

Follow-up: the drawing function still bugs out on me. It's not a 1:1 correlation, but I've noticed that it seems sometimes to be related to the zoom function? My touchpad is a little twitchy, so sometimes it'll zoom in when I wasn't trying to do that at all. I've noticed that the draw function will disable sometimes.

Or other times, if the draw function is invisible, I can sometimes convince it to come back by zooming out and in. It doesn't always work, but sometimes it does! ^ Hope this helps

2986330e38386f92fee4774b0c54ed66
Kimtaro Admin at 2018-01-30 19:32:19 UTC

@Redarian thank you for adding these detailed notes. I'll try to see if I can reproduce with the zooming behaviour you describe. I should also note that I've found a possible bug on the server side that I need to fix. But my hunch is that there is a slew of separate issues working together to produce all the inconsistencies that everyone's seeing.

44df21eb528311478eda0b1f6a4b29a4
nitzi at 2018-02-07 17:05:19 UTC

@Kimtaro I'm getting the following errors:

[Violation] Added non-passive event listener to a scroll-blocking 'touchstart' event. Consider marking event handler as 'passive' to make the page more responsive. See https://www.chromestatus.com/feature/5745543795965952
↑ I'm getting that 4 times, twice for touchstart and twice for touchmove. It's for these two lines (line#18635&18638) in file "https://assets.jisho.org/assets/application-f4437663be46deb4d24232a3c90d4f45beb4532081ed594fd9e18bdc5e02f452.js":
this.canvas.addEventListener('touchstart', this.onStart.bind(this), false);
this.canvas.addEventListener('touchmove', this.onMove.bind(this), false);

Another error, same as Redarian:
The SSL certificate used to load resources from https://bam.nr-data.net will be distrusted in M70. Once distrusted, users will be prevented from loading these resources. See https://g.co/chrome/symantecpkicerts for more information.
↑ This shows up in the sources tab as a squiggly red underline on the first line - "<!DOCTYPE html>"

2986330e38386f92fee4774b0c54ed66
Kimtaro Admin at 2018-03-04 07:25:18 UTC

@nitzi Thank you, that first error looks like it could be the culprit and will definitely help me debug. The second error can be safely ignored.

to reply.