8 Replies ・ Started by EJ at 2017-01-21 05:10:26 UTC ・ Last reply by Kimtaro Admin at 2017-02-08 19:13:18 UTC

"f" in draw function

This website is amazing! Thank you for developing it. There is one issue I encounter which stumps me.

Nine times out of ten, when I use the draw function to search for a kanji, the letter "f" appears in a small box next to the area where you draw the kanji. When that "f" appears, I cannot draw anything, and then an "f" appears in the long white rectangular space where the chosen kanji would appear. Also, if I tap the little "f" box, "f" comes up in that same long white rectangular area. If I tap it seven times, seven "f"s appear.

I have switched to searching by radicals now, it would live to use the draw function. What is this "f" and how can I use "draw" again?

I am using an iPad and iPhone (operating systems all up to date)


EJ at 2017-01-21 05:12:09 UTC

Autocorrect issues. I meant, "I would love to use the draw function".

jakobd2 at 2017-01-21 05:54:16 UTC

Doesn't happen for me. Are you using Safari? Did you try clearing cookies/cache?

Kimtaro Admin at 2017-02-02 20:33:13 UTC

I can't replicate that specific bug in Safari or Chrome on iOS. But there are a few mobile issues with the drawing function that I need to fix.

EJ at 2017-02-03 03:12:03 UTC


Thanks for the suggestion.

Yes, when this happens I am using Safari.

I cleared cookies/cache on the iPad as suggested, and for the past week it has been working A-OK. iPhone I haven't cleared the cookies/cache yet and so the pesky "f" thingy continues to appear. I shall clear that up now.

Thanks again!

EJ at 2017-02-03 03:17:41 UTC

By the way, if you wish me to send a screen grab so you can see what I mean, happy to do so. Let me know where to send it if you are curious!

jakobd2 at 2017-02-03 04:45:09 UTC

In the mean time I was able to get the same "f" appearing in the input box on my iPhone while drawing a kanji. However, I couldn't find a way to reproduce it after spending 10+ minutes on it. It doesn't seem to happen often.

EJ at 2017-02-03 05:01:54 UTC

I'll crack on with using the drawing option with cleared cache/cookies. Will let you know if the "f" issue reappears.

Thanks for looking into it!

Kimtaro Admin at 2017-02-08 19:13:18 UTC

Thanks for helping to narrow this down @jakobd2. I know I've seen it as well, but can't replicate reliably. I'll also keep my eyes open.

to reply.